The "Background Intelligent Transfer" service always stops and it's Startup Type is always reset to "Manual" after a few minutes

Joined
Mar 14, 2023
Messages
5
Reaction score
0
Several times I started the "Background Intelligent Transfer" service and set it's Startup Type to "Automatic" but these two actions are always undone after few minutes the "Background Intelligent Transfer" service is stopped and it's Startup Type is again "Manual".

Why this is always happening?
 

RogerOver

Well-known member
Joined
Jun 14, 2022
Messages
351
Reaction score
51
Why this is always happening?

I do not know what is exactly happening on your computer, but you could run the "Windows update troubleshooter", which is in "Settings\Troubleshooters\Other troubleshooters".
It can not only repair "Windows update", but also the "BITS service" !
Good luck
 

Vote:

Sir_George

Well-known member
Joined
Mar 6, 2022
Messages
206
Reaction score
20
Several times I started the "Background Intelligent Transfer" service and set it's Startup Type to "Automatic" but these two actions are always undone after few minutes the "Background Intelligent Transfer" service is stopped and it's Startup Type is again "Manual".

Why this is always happening?
See the link below for some information that might help.

 

Vote:

RogerOver

Well-known member
Joined
Jun 14, 2022
Messages
351
Reaction score
51
Sorry, it is in Settings\System\Troubleshotters\Other troubleshooters

@Sir_George
I think there is no more separate BITS troubleshooter in the latest version of WIn 11 !
 
Last edited:

Vote:
Joined
Mar 14, 2023
Messages
5
Reaction score
0
I ran the BITS troubleshooter and it says that it fixed "Service registration is missing or corrupt" and after that the service is running and it's startup type is set to "Automatic (Delayed Start)".

I believe that the problem is solved now but I will confirm this if the service won't stop and reset back to manual after 24 hours.

Thank you for your suggestions.

Sorry that I was away, I was busy in reading and finding solutions to this problem that I forgot to check this.

The thing is that this post was awaiting approval by a moderator or administrator for too long that this caused me to be away and busy on something else for too long.

EDIT:

Few minutes passed after the troubleshooter returned to me with this message and the "Background Intelligent Transfer" service is again stopped and it's startup type is again set back to "Manual".

There is something that causes this.

I ran the BITS troubleshooter again and this time it says that "Troubleshooting couldn't identify the problem".

I will see the link that Sir_George posted in hope that I will find there at least one solution to this problem.
 
Last edited:

Vote:
Joined
Mar 14, 2023
Messages
5
Reaction score
0
It looks like that every time the BITS troubleshooter returns to me with the message "Troubleshooting couldn't identify the problem" I see that the "Background Intelligent Transfer" service is running and it's startup type is set to "Automatic (Delayed Start)" but this service is again stopped and it's startup type is again reset to "Manual" few minutes later.

It appears that the BITS troubleshooter automatically detects that the "Background Intelligent Transfer" service is stopped and it's startup type is "Manual" and then automatically starts the "Background Intelligent Transfer" service and sets it's startup type to "Automatic (Delayed Start)" before the BITS troubleshooter returns to me with that message but this is not a permanent solution but a temporary solution that lasts only few minutes until the "Background Intelligent Transfer" service is again stopped and it's startup type is again reset to "Manual".

Looks like that I must read what Sir_George sent to me.
 
Last edited:

Vote:

Sir_George

Well-known member
Joined
Mar 6, 2022
Messages
206
Reaction score
20
It looks like that every time the BITS troubleshooter returns to me with the message "Troubleshooting couldn't identify the problem" I see that the "Background Intelligent Transfer" service is running and it's startup type is set to "Automatic (Delayed Start)" but this service is again stopped and it's startup type is again reset to "Manual" few minutes later.

It appears that the BITS troubleshooter automatically starts the "Background Intelligent Transfer" service and sets it's startup type to "Automatic (Delayed Start)" before the BITS troubleshooter returns to me with that message but this is not a permanent solution but a temporary solution that lasts only few minutes until the "Background Intelligent Transfer" service is again stopped and it's startup type is again reset to "Manual".

Looks like that I must read what Sir_George sent to me.
I hope something there helps. Best of luck!
 

Vote:

RogerOver

Well-known member
Joined
Jun 14, 2022
Messages
351
Reaction score
51
There was no return from your side concerning the "Windows update troubleshooter" !

If this does not work, you could try to disable BITS trough cmd prompt and restart it; see here (solution 3 or 4): https://thecategorizer.com/windows/enable-and-disable-bits-windows/)
I'd even reboot the computer after having disabled BITS and then restart BITS after reboot (if it doesn't run already again).
 
Last edited:

Vote:

RogerOver

Well-known member
Joined
Jun 14, 2022
Messages
351
Reaction score
51
Several times I started the "Background Intelligent Transfer" service and set it's Startup Type to "Automatic" but these two actions are always undone after few minutes the "Background Intelligent Transfer" service is stopped and it's Startup Type is again "Manual".

Why this is always happening?

Hi, I think I found an explanation to your problem.

You say that you set the BITS service to "Automatic" and that these actions are always undone.

This seems to be normal, as this service should be set to manual !
In any case it is set to manual on my system and this is confirmed here: https://www.winhelponline.com/blog/restore-bits-service-windows/
 

Vote:

virgored

New member
Joined
Jun 8, 2023
Messages
1
Reaction score
0
I have a similar Issue, we need the BITS Service running for a couple of hours but when we set it to 'Automatic' and 'Running' the Service stops and reverts back to manual

An way of having the service run for a couple of hours then set it back to Manual?
 

Vote:

Xploit Machine

Well-known member
Joined
Nov 29, 2022
Messages
704
Reaction score
67
Mine is set to MANUAL since I do not want Windows to do multiple background tasks which affects my system and internet performance while I'm using computer everyday .. for updating I would just do manual checking .. kinda twice a week :)

1686241308246.png
 

Vote:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top