Problems opening websites after PC prog useage.

MrGlenn

Member
Joined
Oct 13, 2021
Messages
17
Reaction score
1
Hello W11 Gang.

I recently upgraded from windows 10 to windows 11. Can't say that I'm a fan but getting used to it. There is however one irritating 'problem' that I am not clever enough to understand (or fix) > After using a few prog's for a while (3DSMax seems to be the biggest culprit), i will close everything down as usual, but then find that I am unable to access a number of websites, like Amazon.uk for instance - constant spinny blue circle thingy is all I get. The ONLY way that I can 'fix' it is to restart the PC, whereupon such websites open instantly. I use Microsoft Edge - Chrome gives me other problems!

For the record, my spec;s are> CPU = i5 9600K, 32GB Corsair RAM, MSI RTX 3080Ti (Factory OC), Full fibre 500 Gbs internet.

My best guess is that it might have something to do with memory, although I'm unsure how to find out. Any help would be much appreciated, 'cos getting a bit annoyed at having to keep restarting PC.

Many thanks
Glenn
 

Bighorn

Well-known member
Joined
Feb 27, 2023
Messages
583
Reaction score
84
One thing I'd try before rebooting is to right-click the Taskbar, choose Task Manager then right-click Window Explorer and Restart it.
 

MrGlenn

Member
Joined
Oct 13, 2021
Messages
17
Reaction score
1
Many thanks for your reply. Unfortunately it hasn't helped. I can't even open these web pages without restarting the PC. I have used Chrome a couple of times tho, and that SEEMS to be working fine, without a reset. Could it be some kind of bug in MS Edge? I would think not, or others here would be reporting the same. Maybe I'll just use Chrome as default browser for a while and see what happens. It will be a pain in the a** re-entering all my different passwords tho' !!
 

MrGlenn

Member
Joined
Oct 13, 2021
Messages
17
Reaction score
1
UPDATE: After much kerfluffing about, I finally dumped MS Edge and have moved to Chrome as the default browser. Done much testing and tweaking; all SEEMS to be working well - so far. Had some fun creating the Chrome ico file!
 

MrGlenn

Member
Joined
Oct 13, 2021
Messages
17
Reaction score
1
Well, that didnt last very long. Yesterday, I did little more than a bit of browsing and online banking. I then hit the 'Sleep' key (as I always do). This morning, I rattle a couple of keys to wake the PC, then almost nothing loads with Google chrome. Maybe it's just me - a bit of an old twit that's doing something stupidly wrong? So I re-start the PC and once again all is well. Close to giving up now. Maybe i'll go back to the old fashioned days of pen, paper and postage stamps!!
 

Bighorn

Well-known member
Joined
Feb 27, 2023
Messages
583
Reaction score
84
Maybe i'll go back to the old fashioned days of pen, paper and postage stamps!!
Get the Forever stamps now, supposed to be going up soon. And the newest scam on MSN news last week was about counterfeit stamps.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top